linux下搭建lamp环境以及安装swoole扩展
分类:互联网事 热度:

  安装有2种方式:编译安装和PECL安装,编译安装稍微麻烦一些,但是速度比较快。PECL安装简单,等待时间可能会长一点。

  // 设定进入phpMyAdmin管理MySQL的方式,共有三个选项:config、http、cookie。config是按配置文件登录,为默认方式, 无需任何确认;http是使用HTTP登录管理,在Apache模块安装下才能支持;cookie是最通用的管理方式。后两种方式的用户名和密码都是直接到数据库中验证。

  4)到此已完成LAMP环境搭建,linux下搭建lamp环境以及安装swoole扩展我们来写一个php脚本测试是否apache可以解析php文件: 新建一个php文件,phpinfo.php

  1)仅支持Linux操作系统,核心代码兼容FreeBSD,需要调整某些编译的参数和细节才能通过

  也可使用以下命令搜索可用的php模块1)安装相关模块:为了让PHP支持MySQL,我们可以安装php-mysql软件包;

  3)gcc4.4以上版本。核心代码兼容clang,需要关闭CPU亲和设置特性

  3)设置完成后,保存config.inc.php文件。确保MySQL和Apache处于运行状态。打开浏览器,在其中输入,将会打开phpMyAdmin的管理界面

  2)切换至/phpmyadmin目录,编辑.php文件,更改下述配置参数的配置:

  # mysql -u root -p回车直接进去,或者随便输入一个密码,登陆后结果会显示mysql版本信息

  使用yum自动安装的php版本比较旧,一般都是PHP5.3.3这个版本,很多php扩展功能都不被支持。所以我们有的时候有必要升级一下php版本。

  1)默认使用centos yum安装的MySQL不是5.5版本的,我们需要增加两个新的repo

上一篇:linux Jumpserver跳板机堡垒机部署安装使用教程 下一篇:注册熊掌企业号时是没有互联网新闻信息服务许
猜你喜欢
各种观点
热门排行
精彩图文